Working with Your Data > Importing Data > Points

Navigation:  Working with Your Data > Importing Data >

Points

Points represent discrete locations in space (XYZ) where attribute information is known. Examples of points data include: ground surface or subsurface elevations, well tops, locations with known aquifer hydraulic properties, etc. Typically, this information may come from drilling wells or monitoring events where information is gathered from a specific location.

Once imported, points data can then be interpolated to generate surfaces. These surfaces can be used to create conceptual model horizons, or for defining property values for structural zones. For more information on creating surfaces from points data see Creating Surfaces.

Visual MODFLOW Flex supports the following file types for points data:

Shapefile (*.SHP)

AutoCAD (*.DXF)

Text (*.TXT )

Comma-Separated Values (*.CSV)

Access Database (*.MDB)

Excel (*.XLS)

 

For Points data, the following data must exist in separate columns, in your source data:

X

Y

Elevation

Attribute 1 (optional) (e.g., conductivity)

Attribute 2 (optional) (e.g., layer 2 elevation)

etc..

 

To import points data, follow the steps below:

Right-click in the Data Explorer, and select Import Data... from the pop-up menu. The import dialog will open:

 

 

 

Select Points from the Data Type drop-down list. Click the [...] button and locate the source file.

Enter a Name and a Description (optional) for the imported data, and click [Next] to continue.

The next step allows you to preview the source data before importing, and will vary depending on which file type is selected.

 

For .CSV and .TXT files (shown below), select the appropriate delimiter from the Delimiters frame, e.g., if it is a *.CSV file, you would select “comma”. Specify which row to start importing from using the From row selector.

 

 

For .XLS files (shown below), select which Excel worksheet to import from the Select Worksheet drop down list. Also, you can choose which row to import from using the From row selector.

 

 

 

For .MDB files (shown below), you can choose to import data from a table or a query, by selecting either the View Tables or View Queries radio button. Select the desired query/table from the Select Table or Query drop down list box.

 

 

Next, select the Coordinate System of the data being imported. If the coordinate system is different than the one defined in the project settings, VMOD Flex will perform a geo-transformation, converting all coordinates to the project’s coordinate system. Click the [Next>>] button to continue to the next step.

 

 

Next, set your Data Mapping by mapping columns in the source data to the target fields in Visual MODFLOW Flex. A read-only preview of the source data is presented. The process of data mapping is described in the following section in greater detail.

 

Data Mapping

The first column in the Data Mapping table, named Target_Fields, contains the required target fields for the data object. The second column, named Map_to, allows you to match the fields in the source data to each required target field.

If the column labels in the source data are identical to the labels of the target fields, Visual MODFLOW Flex will automatically map the columns for you. However, if the labels differ, you must map the columns manually.

To map a source field to a target field, select the corresponding source field from the drop list box in the Map_to column. The drop down list displays the column headers in the data source file.

 

For example, in the figure above, the elevation field in the source data is labeled “Z”. To map this field to the target field “Elevation”, select “Z” from the adjacent drop down list.

If the file you are trying to import is a 3D Shapefile (with Elevation defined), then Visual MODFLOW Flex should automatically detect this, and you should not need to map the Elevation attribute at this step.

Source fields that are not required, can be mapped by creating a new attribute. To create a new attribute, click the  Add a new attribute button. A new row will be added to the Data Mapping table.

 

In the Map_to column, select the desired attribute field in the source data, from the combo box. Repeat for additional attributes. You can delete a mapped attribute by selecting the row from the Data Mapping table, and then clicking the  Delete button.

Use the Unit Category and Unit columns to define the units of a mapped field. If the specified units are different than those defined in the Project Settings, Visual MODFLOW Flex will automatically convert the data in the source file to the default project units.

The Multiplier column allows you to multiply all values in the mapped field by a specified multiplier value.

The Data Type column allows you to define the data type. Select from the following options: Numeric, Text, Boolean, Date and Time. For example, if the mapped column contains text data, select Text from the drop down list.

Once the data mapping is complete, click the [Next] button to continue to the validation dialog.

 

Data Validation

The final step involves validation of the data being imported. This step will ensure that the data set contains valid data for each of the mapped fields.

 

In the top half of the dialog, Visual MODFLOW Flex will list any mapped fields that contain invalid data, along with a reason for why they are deemed invalid. The data validation rules for each mapped column are as follows:

X and Y values must be a numeric value, and present in each row of the mapped data.

Data columns will be deemed invalid if Visual MODFLOW Flex detects a null (blank) field.

Data in each column must satisfy the specified data type.

 

If invalid data exists, you can choose to import this data anyway. Otherwise, you can select the Do Not Import Rows with Warnings check box, and Visual MODFLOW Flex will not import any rows deemed invalid.

In the bottom half of the dialog, there are two options:

Show only errors and warnings: When selected, only the records deemed invalid will be shown in the preview table. Records that are deemed invalid will be colored either red (error) or yellow (warning).

Show this amount: When selected, you can view a specified number of records in the preview table below. Enter a value, and then click the [Apply] button to show the records (both valid & invalid) in the preview table.

 

When you import pumping well schedule data or head/concentration observation data in Absolute time format, Visual MODFLOW Flex will check the date values against the start date you defined in the modeling objectives;

For pumping well schedules, any wells that have dates before the model start date will be flagged as warning, since these data cannot be used when you create Pumping Wells Boundary condition object. Likewise

For head/concentration observations, any wells that have dates before the model start date will be flagged as warnings, since these observations cannot be used as calibration points in the numerical model.

 

Click the [Finish] button to import the data. Once imported, a data object will be added in the Data Explorer.

 

 


Page url:http://www.waterloohydrogeologic.com/help/vmod-flex/index.html?importing_points_data.htm