Software FAQ
General
Am I eligible for a free upgrade?
If you currently subscribe to the Waterloo Hydrogeologic software maintenance plan, you are eligible for a free upgrade. If you do not subscribe to the Waterloo Hydrogeologic software maintenance plan, please contact our sales team sales@waterloohydrogeologic.com to obtain an upgrade quote.
Visual MODFLOW Flex
What is MODFLOW?
How do I export contours for heads?
The way to export contours for heads is to:
• Display heads in a 3D viewer:
– Make sure the 3D view is checked on in the Views panel
– Make sure the Heads are checked on in the Model Explorer tree
• Make sure the 3D view is the active view by clicking on the view screen (note the title bar of the active (sub)view is highlighted in light blue as shown below):

• Right click on Heads in the Model Explorer tree, and select Settings
• In the settings window
– Turn on the style that renders contours (i.e. style > three slices for a structured grid and style > colormap > isolines for an unstructured grid) and set up the contours with the desired number/interval of contours
– Go to the Time node under settings and select the desired time to export
– Apply your display and time settings
• Right click on Heads and select Export Contours
• Select the desired destination folder and file name
• Click Save
NOTE: Outputs will only be available for time that were explicitly set during the model translation step. For heads, the output times selected at under the Output Control settings. By default, the heads are only set to be written for the last time step in a stress period. Make sure the heads are written to binary for each time step that you want to visualize/export to contours. Please consult the documentation for other outputs.

Similar instructions apply for other outputs such as Concentrations, Water Table, and other outputs. The exception to this is exporting contours for the water table in an unstructured grid; our development team is working on this and we will include that functionality in our next release, Flex 11.0
Does Visual MODFLOW Flex support variably saturated groundwater flow modeling including in the unsaturated vadose zone?
Yes. Visual MODFLOW Flex can simulate groundwater flow in variably saturated porous media. Depending on how robust a solution your situation requires, you can use either the UZF package or MODFLOW-SURFACT:
• The UZF package (available in MODFLOW-2005 or MODFLOW-NWT models and is included with Flex Pro and Premium) simulates saturation levels and flow through the vadose zone as a series of pseudo-cells along the wetting front with flow limited to 1D vertical flow only. You can use UZF to specify an initial water content and specify an initial recharge rate to estimate the water content in the soil column above the water table and the amount of recharge that reaches the water table
USGS Reference: https://water.usgs.gov/ogw/modflow/MODFLOW-2005-Guide/index.html?uzf_unsaturated_zone_flow_pack.htm
• MODFLOW-SURFACT (which is available as an add-on to Flex developed by our partner HydroGeologic Inc.) includes an implementation of the full 3D Richards equation with van Genuchten or Brooks Corey saturation/pressure relationships is likely the most robust solution available for estimating unsaturated flow. A demo version of SURFACT is included with our installers (limited to models with 10,000 or fewer cells) may be used to evaluate the difference in performance between the two models.
MODFLOW-SURFACT Reference: https://www.waterloohydrogeologic.com/modflow-surfact-flow/
Please refer to the following topics in our documentation for more details:
Is it possible to build a graph of Drawdown vs Time in Flex?
Yes, you can create graphs of Drawdown model outputs using Flex.
You can use the Time Series Viewer to do it in the application. This is accomplished by right-clicking the Drawdown output and selecting Time Series Viewer:

In the open tab, cells can be selected for display by pressing the gear button and navigating to the Selected Cells option under the Style node. Flex will then display a graph of the drawdown in the selected cells:

Alternatively, model results can be exported in .CSV format and graphed in third-party programs like Excel. To do this, right-click the Drawdown model output, select “Export” and save the file as a .CSV:

Can I run transport simulations with Visual MODFLOW Flex?
Yes, with Visual MODFLOW Flex 2013.1 and later you can run contaminant transport models with MT3DMS. Click here to learn more.
Can I apply 'Evapotranspiration' to different layers during the simulation?
Similar to Recharge, the Visual MODFLOW Flex interface provides an option to apply “Evapotranspiration” to different layers during the simulation
- To the top layer
- To the top-most active layer
What Lake Package (LAK3) capabilities are supported in Visual MODFLOW?
When defining a lake boundary condition, there is now an option to define horizontal leakance explicitly; this is important when there is both horizontal and vertical flow between the lake and aquifer, which is common in quarries or mine tailing ponds that have steep walls.
In the Output, there is a new Lake Budget option for Graphs that allow for showing time series plots of the lake parameters: stage, precipitation, evaporation, runoff, volume changes. You can chart results from a single model or load multiple model results on the same plot, for comparing different model scenarios.
What is MODFLOW -USG?
MODFLOW-USG is a new version of the MODFLOW groundwater flow simulation code developed by the United States Geological Survey (USGS) which uses unstructured grids instead of rectilinear grids to discretize the model domain.
What is an unstructured grid? How is it different than a structure grid used in MODFLOW-2005
An unstructured grid is made up of triangular, rectangular or other polygon shaped geometries individually or in combination to discretize the groundwater model domain. This is in contrast to previous versions of MODFLOW, including MODFLOW-2005 which uses structured, rectilinear grids. Unstructured grids require the use of the finite volume method whereas traditional structured grids are used with the finite difference method.

Structured finite difference MODFLOW-2005 grid (left) and an UnStructured grid with Voronoi Grid (middle) and Quadtree Grid (right) for MODFLOW-USG
What unstructured grid geometrics are supported in Visual MODFLOW Flex?
Although MODFLOW-USG can be used with any grid geometry – triangles, rectangles, polygons – Visual MODFLOW Flex supports unstructured grids made up of polygonal Voronoi Cells or rectangular Quadtree cells.
Why are my grid cells turning pink during refinement?
A common problem when refining finite difference grids is high aspect ratio cells. Cells have a high aspect ratio when the ratio between their height and width is far away from 1. By default, the “Edit grid” window will highlight cells that share a face with an aspect ratio greater than 1.50 pink:

These cells can – but not always! – cause stability and convergence problems when MODFLOW runs. Because refinements to finite difference grids are carried out all the way to the model edges, it’s common to have bands of high aspect ratio cells extending orthogonally from your refined areas of interest.
How to deal with high aspect ratio cells:
Option 1: Is it a problem?
As mentioned above, having high aspect ratio cells is not always a problem, particularly when hydraulic gradients are not excessively steep in the area. It’s worth running the model to see if the model converges and produces sensible results. If so, you might simply ignore them.
Option 2: Can you refine the entire model?
Partial refinement of the model is a method to increase resolution in areas of interest while minimizing the resultant increase in computation times. However, for many models the computation times aren’t that long to begin with. If feasible, you should consider uniformly increasing the grid resolution.
Option 3: Unstructured grids, MODFLOW-LGR
For some highly refined model domains (e.g. regional-scale models with site-scale areas of interest), the above options won’t work. Thankfully, Flex includes plenty of tools to efficiently discretize these kinds of model domains.
One option is unstructured grids, available with MODFLOW 6 and MODFLOW-USG. These grids don’t discretize space in the same way as finite difference grids and can lead to much more efficient local refinement for some models. See the primer on our website for more information.
Another option is local grid refinement, or MODFLOW-LGR. Using MODFLOW-LGR, you can embed MODFLOW models (called “child grids”) inside of a larger one (the “parent grid”). See the Flex documentation for more information and resources on MODFLOW-LGR.
Option 4: Graduated refinement
If none of the above options work for you, the final option is to refine your model on a gradient, so that your chosen maximum aspect ratio is never violated. An example for the above grid is shown below, using a maximum aspect ratio of 1.5:

To do this method, simply refine the outer highlighted edges by the largest ratio you can to satisfy the criteria, and work outwards until the highlighted cells disappear. In the above example, the interior cells were originally refined by three times. The rows and columns next to them were refined by two, and then the rows and columns next to those were refined by 3/2 (exactly satisfying the 1.5 max ratio threshold).
As a consequence, however, this grid refinement is not very efficient. After increasing the resolution of a 2-by-2 cell area by 3 and conducting graduated refinement, our model area has grown from being 20 cells by 20 cells to 28 by 28, an increase of nearly double.
What are Voroni Cells and Quadtree Grids?
Voronoi Cells
One of the types of unstructured grids is supported in Visual MODFLOW Flex. Voronoi Cells are a special type of polygon that honors the Control Volume Finite Difference (CVFD) constraints required by MODFLOW-USG. Using this grid geometry with MODFLOW-USG results in an efficient and robust numerical grid that can handle complex hydrogeological geometries and boundaries with ease – similar to triangles, but with a higher degree of accuracy.

Learn more about Voronoi Cells.
Quadtree Grids
Quadtree Grids are one of the types of unstructured grids supported in Visual MODFLOW Flex. Quadtree grids are based on locally refining rectilinear grids by recursively subdividing cells into four equal quadrants. This allows you to locally refine the grid around non-linear features such as streams and lakes without having to carry those refinements laterally across the entire model domain as occurs when using fully structured rectilinear grids.
Using this grid geometry with MODFLOW-USG results in an efficient numerical grid that can handle complex hydrogeological geometries and boundaries with ease. However, the use of Quadtrees can introduce some errors as the geometry of Quadtree grids does not adhere to the assumption inherent in the Control Volume Finite Difference approach utilized in MODFLOW-USG that shared cell interfaces occur at the perpendicular bisector of the respective cell centroids (see discussion below on Ghost Node Correction [GNC]).
What is Ghost Node Correction (GNC) and is it used for Voroni Grids or Quadtree Grids?
Ghost Node Correction is a technique that is applied to some unstructured grid types (e.g., Nested or Quadtree Grids), whose geometries do not inherently satisfy the requirements of MODFLOW-USG. One of the geometric constraints for the Control Volume Finite Difference approach used in MODFLOW-USG is that the line formed by connecting the centroids of two adjacent Finite Volume cells must perpendicularly bisect the shared cell interface. While Voronoi Tessellation by definition fits this criteria, other grid types (such as Delaunay Triangulations and nested or Quadtree Grids) do not strictly conform to this constraint.
In order to permit the mathematical solution of the Finite Volume Method certain grids, the USG package employs a technique called Ghost Node Correction (GNC) in which a temporary ‘ghost’ node is created within a cell such that it meets the geometric constraints and the equations may be solved. This solution at the ghost node is then interpolated (corrected) back to the actual cell center point, resulting in a Ghost Node Correction within each cell. (http://pubs.usgs.gov/tm/06/a45/pdf/tm6-A45.pdf)
The ghost node correction package is generally not required when using Voronoi Grids because by definition they satisfy the geometric conditions required for the Control Volume Finite Difference approach used in MODFLOW-USG.
The use of Quadtrees may introduce errors in the simulation results as the geometry of Quadtree grids does not adhere to the assumption inherent in the Control Volume Finite Difference approach utilized in MODFLOW-USG: that shared cell interfaces occur at the perpendicular bisector of the respective cell centroids. The interfaces between neighboring cells with different degrees of refinement will occur at an angle that departs from perpendicularity and the distance between the centroids will become increasingly asymmetric as the relative degree of refinement between the cells increases. In cases where the model is smooth (that is the model properties, cell elevations/thicknesses, aspect ratio between adjacent cells is small [2:1]) and/or the non-conforming cells are located far from the area of interest, the resulting error may fall within tolerances that are acceptable to the modeler. For cases where this error may be unacceptable, Visual MODFLOW Flex supports the MODFLOW-USG Ghost Node Correction (GNC) package which corrects for this potential source of error. Note that the use of the GNC package is likely to increase model run times.
What are the benefits of MODFLOW-USG over MODFLOW-2005
Increased Simulation Accuracy
Unstructured grids permit local grid refinement along model features such as wells and boundary conditions, in addition to supporting fully discontinuous layers, both of which deliver high resolution detail and accuracy around areas that matter the most.
Reduced Simulation Runtimes
Traditional MODFLOW grid refinement often results in an excessive number of grid cells outside the areas of interest which leads to an inefficient numerical model with unnecessary long run times. With unstructured grids, the grid refinement is focused only to the areas of interest, resulting in much fewer grid cells, more stable grid structures, and therefore reduced run times.
Further Reading:
Case Study: MODFLOW-USG Yields 90% Reduction in Run Times for Regional Groundwater Model
Superior Modeling of Complex Geology
Unstructured grids are flexible and conform easily to the natural variability found in surface features and subsurface stratigraphy. Unstructured grid layers permit discontinuous layers that pinch-out to zero thickness, providing a more realistic representation of complex hydrogeological conditions, and improved model stability.
Increased Numerical Stability
Unstructured Voronoi grids in Visual MODFLOW Flex are composed of a special type of polygon called Voronoi Cells that are generally superior to other unstructured grid geometries (nested grids, Quadtree grids) as they completely honor the Control Volume Finite Difference (CVFD) constraints, and therefore do not require the Ghost Node Correction (GNC) package. In addition, cell centroids will coincide exactly with conceptual wells and boundary condition feature vertices. This results in an efficient, robust and dependable numerical grid, with improved convergence and accuracy.
What modeling applications are best suited for MODFLOW-USG?
MODFLOW-USG can be used to simulate groundwater flow for virtually any application. However, It’s ability to handle complex geology makes it ideal for applications in mining where steep slope geology is often encountered. Flexible grid refinement capabilities also make it suitable for large regional and watershed scale models.
What process and packages are supported with MODFLOW-USG? And is MODFLOW-USG available in all editions of Visual MODFLOW Flex?
The following processes and packages are supported in MODFLOW-USG:
- BAS, DIS, BCF, LPF, HFB
- CHD, FHB
- WEL, DRN, GHB, RIV
- STR, SFR, LAK, GAG
- SUB
- New Packages: DISU, CLN, GNC, SMS
MODFLOW-USG & Visual MODFLOW Flex
MODFLOW-USG is only available in the Professional and Premium editions of Visual MODFLOW Flex.
My model run crashes, finishes with a “no mass balance information error” or does not converge:
This usually means your model may have non-convergence or stability issues. Please refer to our Blog Post about common troubleshooting steps to resolve these issues.
Is it possible to convert my MODFLOW-2005 model to a MODFLOW-USG model?
Yes. If you currently use Visual MODFLOW Flex, you will already have a 3D conceptual model that defines the geologic layers, properties and boundary conditions independent of the grid. To run your model with MODFLOW-USG, simply auto-generate the unstructured grid and then run the simulation. Visual MODFLOW Flex’s multi-model environment allows you to manage both your MODFLOW-2005 and MODFLOW-USG models within the same project, and both models can be easily compared side-by-side.
If your model currently exists in Visual MODFLOW Classic, you will need to import your model into Visual MODFLOW Flex before you can run the model using MODFLOW-USG.
Does Visual MODFLOW Flex support 64-bit versions of MODFLOW engines?
Yes, you can leverage the power of 64-bit versions of the MODFLOW engines during running of your models to speed up your run time, if you are running 64-bit version of Windows. This support is available for all supported Engines in the Professional and Premium versions of Visual MODFLOW Flex.
Does Visual MODFLOW Flex support parallel processing and SAMG V.2?
Parallel Processing
If your computer contains multiple processors, or dual core processors, you can leverage the power of parallel processing for your flow simulations using Visual MODFLOW Flex simulations using PCG, WHS, or SAMG solvers can be solved over multiple processors reducing the simulation run time. Note that the parallel/multi-core version of the SAMG solver is only available in the Premium Edition of Visual MODFLOW Flex.
SAMG
The latest version of Visual MODFLOW Flex supports SAMG v4. This version of the SAMG solver is dramatically faster than its predecessors, and is ideally suited for multi-layered models with heterogeneous properties. The single core-version is available with Professional Edition of Visual MODFLOW Flex, while multi-core version is available with the Premium Edition of Visual MODFLOW Flex.
Does Visual MODFLOW support MODFLOW-NWT?
Yes, the Visual MODFLOW Flex interface supports MODFLOW-NWT package, a version of MODFLOW which provides enhanced capabilities for solving problems involving drying and rewetting non-linearities of the unconfined groundwater flow equation.
Do you have any recommendations for system configuration to improve the performance of Flex?
Unfortunately, due to the number and variety of possible modelling scenarios and system configurations, we do not have the capacity to test Visual MODFLOW Flex (and supported engines) with specific machine configurations and we do not have any special recommendations on system configurations beyond the minimum system requirements. Flex has been designed for use with Windows 10 and Windows 11 machines and will make use of available resources to perform operations provided the machine meets the minimum requirements specified on our website and below.

All of our engines, including SEAWAT have been compiled as parallelized applications using up to date Intel FORTRAN compilers to take advantage of available system resources.
In the Zone budget, can I assume that Drain-Out is the amount of water that is draining out of that zone due to the effect of the Drain? If so, what does Drain-IN mean?
In ZoneBudget, all flow terms (i.e. zone-to-zone and zone-to-BC) are provided with an IN term and an OUT term, regardless of whether the specific Boundary Condition type allows inflows or outflows. The sign/naming convention in MODFLOW and ZoneBudget is such that all terms in the mass balance are with respect to the groundwater cells in the zone, so IN always means that the Boundary Condition (or other zone) is adding water to the groundwater zone and OUT means that the Boundary Condition (or other zone) is removing water from the specified groundwater zone. With these facts in mind, Drain OUT is the amount of water leaving all groundwater cells in the specified zone by means of a Drain boundary condition within that zone. Drain IN is the amount of water entering groundwater cells in the specified zone by means of a Drain boundary condition within that zone; however, since, by definition, drains cannot add water, this term will always be reported as 0.
Hydro GeoAnalyst
Can I complete water quality analyses using Hydro GeoAnalyst or do I need AquaChem?
The features of AquaChem are available in the HGA Plus Edition. For more information, please see the following pages:
Can I complete pumping test analyses with my Hydro GeoAnalyst data?
HGA includes a module to easily create pumping test analysis files for use in AquiferTest. In order to use the Aquifer Test analysis feature, you must first have Aquifer Test (version 2011.1 or later) installed on the local machine.
- With your project open in Hydro Geo Analyst, select Modules > AquiferTest or select the AquiferTest icon from the toolbar. This will launch the Pumping Test Analysis window which allows you to select tables/queries containing the data for the pumping test analysis.
For additional information on configuring your HGA project to work with AquiferTest, please refer to the online help documentation. Once all the required fields have been defined, click the Analyze button to send the data to AquiferTest.
Can I use my Hydro GeoAnalyst data in Visual MODFLOW Flex?
In Hydro GeoAnalyst, you can query the database to determine layers with different lithology and export this data for use in Visual MODFLOW Flex.
For example, the HGA demo project database can be queried to estimate the bottom of a model based on the elevation of the marl unit. To query the model bottom surface, we will need to build a query as follows:
- Add the map ready field by clicking the Add fields button below the “Available to map and plume modules” label. This will add the Station ID, Station Name, X, and Y fields
- Select the Use project coordinates option
- Add the ground surface elevation (station.[Elevation]) and lithologic depth (lithology.[from_]) to the list of display fields
- Add the lithology type (lithology.[soil_type]) to the list of Conditions and set the operator to “=” and the value to “Marl”. This will limit the results to only the stations where marl was found.
- Add a blank field to the list of Display Fields by pressing the add field button, add the expression “station.[Elevation] – lithology.[from_]”, and set the Alias to “Top of Marl”. This expression will calculate the elevation of the top of the marl unit.
- Save and execute the query. Once the database has been queried to determine the model bottom elevations, you can:
- create and export a surface in HGA (using the Map Viewer module) or
- export the query to text file which can be imported into Visual MODFLOW Flex as points which can be used to create a surface.
You will need to adjust the query according to your project fields/data.
Creating Observation Data:
In Hydro GeoAnalyst, you can create a calibration point file by creating a query with the following columns for creating observation well data:
| Name | X | Y | Screen | Measure Point Elevation | Time | Head |
| BH0902 | 2438 | 6556 | 1 | 580.1 | 1 | 602.55 |
Once you have created the appropriate query, you may export the data to a spreadsheet (.XLSX) or delimited text (.TXT) file to import into Visual MODFLOW Flex.
How do I save a backup of my HGA project?
You can save a backup of your HGA project. The backup may include just the database or (as of HGA Version 13.0) it may include the database and the associated project files (for example, saved/exported Print to Office files, map layers, EDD Templates, Plume, etc.). This is useful if you need to create restore points as a data safety protocol, before attempting to make significant changes to the project, or if you need to transfer a copy of the project to someone else. To create a backup:
- You must have sufficient privileges in the database.
- Run Hydro GeoAnalyst on the system that also hosts the SQL Server. Note: SQL Server does not permit saving a back up copy of the database to a mapped network drive; backups can only be saved to a local drive.
- Open the project for which you wish to make a backup.
- From the Project Menu, select Make a Backup…, this will launch the Backup Database dialogue.
- Specify the desired backup location (which should not be project folder of the current project). Select whether you want to include the project files:
- If you do not include the project files, only the database will be archived and the backup file will be saved as a .BAK file
- If you include the project files, both the database and project files will be archived and the backup file will be saved as a .BAKX file
You also have the option to include the “COPY_ONLY” SQL flag. This may be necessary to preserve/maintain DIFFERENTIAL and LOG backup chains under certain IT policies.
- Click OK to initiate the backup.
How do I restore my project from a backup?
You can restore a project from a back up copy of your database (*.BAK file) or from a copy of your database and project files (*.BAKX file). This is useful if you need to restore your data or your entire project from an earlier point in time or if you need to receive a copy of someone else’s project. To restore a backup:
- You must have sufficient privileges in the target database/SQL Server.
- Run Hydro GeoAnalyst on the system that also hosts the target SQL Server. Note: SQL Server does not permit restoring a backup of the database over a network drive; backups can only be restored from a local drive.
- From the Project Menu, select Open from Backup…, this will launch the Restore Database dialogue.
- Specify the backup file and associate project to restore:
- If you have a database only backup, you will need to specify both the database backup file (.BAK) and the project file where you want to restore the project (.HGA).
- If you have a full backup with both the database and the project files (.BAKX), then you only need to select this one file, since the project file (.HGA) is included in the archive.
- Once you have selected either a .BAKX or a .HGA file, then review/update the database restoration target location, including: the Project Name, the target database type (SQL Server or Local Database), the SQL Instance, and the Database Name
Additional information on backing up your database can be found in the online help documentation.
What is the empty purple-blue line at the top of HGA table views?
The purple-blue first line on most HGA table view is a filter line.
The filter line is similar to what you find in Excel when you apply a filter. You can filter to a specific value by using the specific value filter on the right side of a given field:
You can also filter to those values that match a given criteria made up of a general filter type and a value typed filter line:
You can clear a filter for a given field or for the whole table by clicking the appropriate clear filter
button.
More complex searches can be made using the Query Builder.
AquaChem
Using PHREEQC, some of the saturation indices or complexes are not calculated. How should the parameters be defined?
PHREEQC will calculate saturation indices and activities for those parameters which are defined in your database. Also, the saturation indices will require that the PHREEQC component be mapped exactly as it is shown within AquaChem. For more information, visit our PHREEQC help section.
Where can I find the thermodynamic database files?
The PHREEQC database files distributed with the program are installed under My Documents AquaChem PHREEQC. For more information, visit our PHREEQC database page.
Can I use AquaChem features in Hydro GeoAnalyst (HGA)?
Yes, the features of AquaChem are available the HGA Plus. For more information, please see the following pages:
I cannot get the PHREEQC program to run. Where can I find the installer?
You can find and configure the most up-to-date versions of PHREEQC and PHREEQCi (the Graphical User Interface) from the USGS website by following the instructions on our PHREEQC and PHREEQCi installation page.
In AquaChem, can I add new regulatory/compliance Standards? For example, incorporate French regulations, or is it compulsory to use Canadian water quality regulations?
The water quality standards provided in the AquaChem demo project and templates include some Canadian and US standards that are provided as examples only; they are not necessarily up-to-date or comprehensive and are not required to be kept in the project. AquaChem allows you to manage (add, import, remove, edit) these standards and AquaChem supports multiple standards in the same project. To review a given standard, simply select it in the “Current Standard” dropdown menu.
- The Active setting for each standard determines whether or not it will be actively used to compare against sample result values for a given parameter in other parts of the project (e.g. Sample List, Sample Report, Sample Set Editor, Plot Collections, etc.).
- The first three columns are from the imported standard and are not editable once imported (although you can add and delete rows):
- Standard Parameter: the name of the parameter as described in the standard
- Standard: the threshold above which there would be a violation of the standard
- Unit: the unit of measurement for the value of the standard
- The next three columns relate the standard to the project:
- AquaChem Parameter: the name of the parameter in the project database. There are tools at the time of import to automatically correlate differences between the “Standard Parameter” and the “AquaChem Parameter”, including matching CAS numbers. If the automatic match is not successful, you can always manually map an AquaChem Parameter to a given Standard Parameter.
- Effective Standard: the value of the standard based on the unit of the AquaChem Parameter
- Unit: the project unit for the AquaChem Parameter (set in the Parameter Editor)

For more information, visit our Water Quality Standards section.
My sample symbols do not show up on the plot.
Check that you have assigned symbols to that sample(s) using the Symbol Editor.
You may also want to ensure that you have entered data for each parameter required by that plot.
My symbols show up on the plot using a different color or symbol other than what I expected.
Check that you have defined a symbol for the sample(s) using the Symbol Editor. The “unexpected” symbol you are seeing may be the default symbol. Samples with undefined symbols may be shown using the default symbol.
Check which samples are selected in the Sample Picker. Selected symbols will be shown based on the Active Symbol style settings. Samples which are selected in the sample picker or sample list will be shown using a light blue color (
) by default.
After I enter a value for a measured parameter, the 0 after the decimal place is cut off (for example, 7.20 in entered, however AquaChem displays this as 7.2).
This can be corrected by modifying the parameter format. Open the Parameter Editor, select the appropriate measured parameter using the parameter picker, and modify the “Display format” to set the number of decimal places to the desired value.
The station group I created from a sample set includes samples which do not meet the criteria for that sample set. Why are those extra samples included?
Station groups created based on a dynamic sample set contain all of the samples from stations associated with that sample set. Therefore, the sample set associated with a station group will typically contain more samples than what you find in the actual sample set itself. This may be useful in evaluating trends at stations meeting some criteria such as exceedances.
Why does the calculated data tab display an error when I access it?
Parameters required for the calculation have not been mapped. Select Project > Properties from the main menu and review the Parameters If a required parameter has not been mapped, then AquaChem doesn’t know what values to use in the calculation.
No result is available for one or more of the input parameters required for the calculation. If you do not collect the data required for a particular calculation, you can simply hide that calculated value from the Calculated data tab by clicking the Properties [
] button in the toolbar and hiding the calculation(s) that you don’t need.
Is it possible to create two unique Piper plots showing two different sample groups?
Yes! In AquaChem you can define multiple Piper plots (or any other plot type) in one or more plot collections and define the source data for each plot based on one or more different data sources (e.g. Station Groups or Sample Sets).
My samples do not appear in the sample list.
Make sure that you activate a sample set that contains the missing data. If you just imported sample data, you may have to refresh your view(s) by clicking the refresh [
] button. If you have activated a static or dynamic sample set that does not capture newly imported samples then they will not be displayed in the Sample List. To display all samples double-click the ‘All Stations’ sample group in the Project Tree. This will display all samples from the entire project within the Sample List.
I cannot install packages in R-Console.
If you cannot install packages in R using the install.packages() command; please follow the Installing R instructions. Conversely, you can try installing R in a local folder that does not require administrative privileges and pointing AquaChem to this installation location using the R-Console settings.
My R script is not showing anything in the Output window.
The R-Console output window has been streamlined to only output results using the print() command to improve script runtimes and reduce output clutter.
My R script works in RStudio or RGui but not in AquaChem.
Be sure to add a “+” at the beginning of each continued line. R-Console in AquaChem interprets R on a line-by-line basis and unlike RStudio and RGui, you must explicitly continue multi-line commands. Please refer to the differences between standard R and the version of R used in the R-Console in AquaChem.
Can I run AquaChem 13.0 and AquaChem 2014 on the same computer?
Yes. Both versions of AquaChem will run on the same computer provided the system requirements are met for each.
AquiferTest
How can I analyze a pumping test drawdown in a leaky aquifer using AquiferTest?
AquiferTest 12 includes two methods for analyzing pumping test drawdown in a leaky aquifer. The Hantush-Jacob (1955) solution, called “Hantush” in the interface, assumes that storage in the confining layer is negligible, while the Hantush (1960) solution, called “Hantush with Storage” in the interface, includes an additional parameter for aquitard storage. There is an online tool available for choosing an appropriate analysis method in AquiferTest: See our Interactive Decision Tree.
AquiferTest includes a tutorial for performing predictive analysis with test results, see here: Introduction > Quick Start Demo Tutorial > Tutorial 2: Predictive Analysis. This illustrates a typical workflow for simulating and reporting drawdown at a point. Additionally, paid training is available for AquiferTest, which includes several case studies on analyzing and reporting pumping tests.
Can I perform a single well test analysis?
Yes, please see: https://www.waterloohydrogeologic.com/help/aquifertest/demo_exercise_3_single_well_an.htm
There's a lot of 'noise' in my data. How can I minimize that?
New feature in Pro: Use derivative “smoothing” to reduce noise in the dataset. AquiferTest provides three methods for derivative smoothing: Bourdet Derviate (BOURDET 1989), Standard (HORNE 1995) and Regressive (SPANE & WURSTNER 1993). For more information on these methods, please refer to the original texts.
- To open the Derivative Setting dialogue,go to the Analysis tab, and select Analysis> Derivative… , from the main menu. You can apply derivative smoothing to all datasets in the analysis by selecting the Use sample setting for all data option.
- To assign different methods to different data sets, select the ‘Set’ each data set separately option.
The Neuman method is taking a long time to run. How can I speed it up?
New Feature: Neuman analysis now has an option to use tabular interpolation which provides a much faster solution. Currently this is only available in the dimensionless display. The new feature is located in >Main Menu, >Tools, > Options, General tab. Using the tabular interpretation will provide a faster, however slightly less accurate, Neuman solution.
I've used the parameter control buttons to get a 'better' fit but my curves are still not matching?
New feature: Click on the curve, generated from your data, and drag it to your desired best fit location using your mouse. This method provides more flexibility and improved accuracy.
I'm performing a slug test in a high conductivity aquifer. Are there any solution methods suited for this type of aquifer?
The Butler High-K method (Butler et al., 2003) is appropriate for the analysis of slug tests performed in partially penetrating wells in formations of high hydraulic conductivity and those that exhibit inertial effects and oscillatory response.
We have a few lateral drains so we can enhance our recovery. Can AquiferTest handle horizontal drains or only vertical wells?
New feature in Pro: The Clonts & Ramey solution is suited for determining hydraulic properties, i.e., transmissivity, storativity and conductivity anisotropy ratio, from horizontal well pumping test data from confined aquifers.
When I click on the 'automatic' fit button I receive the following error: Warning automatic fit did not succeed". What does this mean and how do I resolve it?
This message indicates that given the data set, the automatic fit was unable to match to the data points. If the automatic fit did not succeed you may consider adjusting the starting parameters by using the Parameter Controls.
- Select the parameter control icon above the analysis graph and use the slider bars to modify the parameter values and to provide a better starting point for the automatic fit.
- Once these values have been adjusted you can perform the automatic fit.
Additionally, if you continue to experience difficulties with the automatic fit, you may consider increasing the number of iterations used for the fit by selecting Tools>Options and browsing to the Constants tab. The automatic fit options are available under this tab.
It appears that AquiferTest assigned random colors to my curves. Can I change the color scheme?
Once in reports, please go to >Maine menu, >Tools from the top menu bar and choose “Options”. In the Appearance tab, you can modify the colors and symbols used.
Can I open AquiferTest projects from older versions in the current AquiferTest version?
Please note that currently only projects created in AquiferTest 4.x onward can be opened in the current version of AquiferTest . To open 3.x AquiferTest projects in the new version please follow these steps:
- Using version 4.x of AquiferTest, open your project and save. Then, using the current AquiferTest version, open your desired project, creating a back up if prompted.
- It is recommended that you ALWAYS create a backup copy of any project files before you open them in the new version. Specifically, ensure that you back up your original MS Access database (.MDB), which contains all project data.
I am unable to print any of my reports in AquiferTest. Please help?
Your printing issue could be the result of a number of settings within AquiferTest Pro that have not been selected. Please consider the following:
Printer Setup
- Click File and select Printer Setup from the main menu
- Select the appropriate printer from the drop down menu since the default may not always be correct.
- Click OK and attempt to print the reports again
*This option will also allow you to select PDFCreator as your printer which will export your reports as PDF documents. You could then open each .pdf file and print them from there.
Printout Selection
- From the Reports tab ensure there is a check mark in the boxes beside each printout you wish to be generated. AquiferTest will allow you to view your reports by highlighting each name, however they will only print when the check mark is showing.
Printer Drivers
- Be sure to update the drivers on your printer, this can be done by selecting your desired printer from the Control Panel on your computer.




