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SEAWAT Tutorial
The following example walks through creating a simple numerical model with variabledensity groundwater flow (using SEAWAT). The exercise is based on the well-known Elder
model.
Objectives
· Learn how to create a project and create a numerical grid for SEAWAT simulations
· Learn how to define new property zones and boundary conditions
· Define inputs/boundary conditions for SEAWAT contaminant transport
· Translate the model inputs into SEAWAT input packages
· Run SEAWAT engines
· Understand the results by interpreting heads, drawdown, and concentrations in several

views
· Check the quality of the model by comparing observed heads to calculated heads, and

observed vs. calculated concentrations
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Version with the Variable-Density Flow Process (VDF) and the Integrated MT3DMS
Transport Processes (IMT). U.S. Geological Survey. Tallahassee, Florida.
Introduction
Saltwater intrusion is a common occurrence along coastlines throughout the world. Saltwater
is denser than freshwater, and consequently will tend to migrate inland underlying freshwater
zones when groundwater resources are depleted or in areas where the water table is low. A
static equilibrium is reached when the freshwater discharge force balances the buoyancy
force due to density. Visual MODFLOW Flex includes the SEAWAT Engine to simulate
saltwater intrusion.
SEAWAT is a computer program for simulating three-dimensional, variable-density, transient
ground-water flow in porous media. SEAWAT was designed by combining a modified version
of MODFLOW-2000 and MT3DMS into a single computer program. SEAWAT contains all of
the processes distributed with MODFLOW-2000 and also includes the Variable-Density Flow
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Process (as an alternative to the constant-density Ground-Water Flow Process) and the
Integrated MT3DMS Transport Process.
This tutorial illustrates a common application for SEAWAT and is based on the Elder
Problem published in the User’s Guide to SEAWAT (Guo and Langevin, 2002). The basic
design of this SEAWAT exercise is shown in the figure below.

The Elder model is commonly used as a benchmark problem for variable-density
groundwater flow, where fluid density is a function of salt concentration. This problem
simulates salt-water intrusion and proliferation through a freshwater aquifer. Molecular
diffusion is the sole mechanism of hydrodynamic dispersion during the simulation, which
runs for 20 years. Salt from the constant-concentration boundary at the top of the model
diffuses into the model domain and initiates a series of complex vortices that redistribute the
salt mass throughout the model. A constant-concentration boundary with a value of zero is
specified for the lowest layer in the model. Two outlet cells with constant head values of zero
are specified for the upper left and right boundaries. These constant head cells allow salt to
diffuse into the model by providing an outlet for fluid and salt mass (Guo and Langevin,
2002).
Create the Project
· Launch Visual MODFLOW Flex.
· Select [File] then [New Project..]. The Create Project dialog will appear.
· Type in project name 'SEAWAT_Elder'.
· Click the [

] button, and navigate to a folder where you wish your projects to be
saved, and click [OK].
· Define your coordinate system and datum (or just leave the Local Cartesian as
defaults).
· Most of the default units will be fine, but we will need to update the conductivity units.
© 2022 by Waterloo Hydrogeologic
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· Select [m/d] as the Conductivity units
· Click [OK] button in the lower right corner of this window.

Note: It is recommended to select the folder
“C:\Users\User_Name\Documents\VMODFlex” as
the default location for your projects. You may then
add a new folder to each individual modeling
project. For the purposes of this project you may
create the sub-folder SEAWAT_Elder. A new
folder can be created automatically by selecting
the ‘Create a folder for the project’ button under
Data Repository.
Before clicking OK, the Create Project dialog should look like the
image below:

The following window will then appear:
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The Select Modeling Scenario allows you to choose whether to proceed with the Conceptual
or Numerical modeling workflow. The conceptual modeling workflow allows you to import
data objects into Visual MODFLOW Flex and to build a conceptual site model (CSM) that is
grid independent. The CSM can then be used as a starting point for several different
numerical models. In other words, numerical models (i.e. with different grid types, engines,
etc.) can be quickly and easily created based on the same conceptual model. This makes it
easy for you to manage several different numerical models with slight variations.
Conceptual modeling is not covered in this exercise, so we will proceed with the numerical
modeling workflow
· Select [Numerical Modeling] and the Numerical Modeling workflow will load.

Proceeding with the numerical modeling workflow will bring you to the first step in the that
workflow, which is to define your model objectives. This step allows you to specify whether
you will be running a fully saturated or variably saturated model, whether it will be a constant
or variable density model, whether contaminant transport will be included, which
flow/transport engines will be utilized, etc.
The selection of these modeling objectives will determine which model- and species-specific
transport properties must be defined (e.g. molecular diffusion coefficients, distribution
coefficients, decay constants, etc.). It is also possible to define default property values at this
time.
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For the default project properties please input the values as shown figure below.
·
·
·
·
·
·
·
·
·
·
·
·
·
·

Select Flow type: Saturated (Variable Density)
Select Simulation type: Groundwater flow
Available Flow Engines: USGS SEAWAT from WH
Select Start Date: today
Type: Kx (m/d) = 0.411 in the Default Project Property Settings frame
Type: Ky (m/d) = 0.411 in the Default Project Property Settings frame
Type: Kz (m/d) = 0.411 in the Default Project Property Settings frame
Type: Initial Head = 1E-6 in the Default Project Property Settings frame
Type: Ss (1/m) = 1E-05 in the Default Project Property Settings frame
Type: Sy = 0.1 in the Default Project Property Settings frame
Type: Name = Salt in the Species Parameters table
Type: Description = Salt in the Species Parameters table
Type: DRHODC = 0.7 in the Species Parameters table
Type: MDCOEFF = 0.308 in the Species Parameters table
Note: MDCOEFF is the species-specific
molecular diffusion coefficient. This parameter is
only used if the multi-diffusion option is set to true
in the DSP package advanced settings. While we
have entered a value here, it will not be used. We
will specify a model-wide molecular diffusion
coefficient at a later step.
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Now that the modeling objectives are defined you may advance to the next step of creating
the numerical grid. Click the white right arrow in the blue circle at the top of the Numerical
Model window to advance to the Define Numerical Model step.
· Click [
] (Next Step) to proceed to the Define Numerical Model workflow step
· Click [Yes] to dismiss the warning message about the model start date
· Now click on the [Create Grid] icon

Define Model Grid
We will now proceed with the model grid creation. You should now see the Create Grid
workflow step, as shown in the image below:

We will create a grid with 1 row, 44 columns and 27 layers. Specifying the number of
rows/columns and the overall grid extents horizontally will be quite easy, as these values can
be specified directly in this window. To specify layer elevations for all 27 layers would be
quite tedious though, so we will initially create the grid with a single layer with the elevations
being the maximum and minimum final layer elevations. We will then refine the initial layer
into 27 equally thick layers.
Please input the number of Rows and Columns and change the number of layers to 1. The
top elevation of the first layer shall be set to 6 m, and the bottom elevation to -156 m.
· Rows = 1 in the Grid Size frame
· Columns = 44 in the Grid Size frame
© 2022 by Waterloo Hydrogeologic
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X Min = 0 in the Grid Extents frame
X Max = 600 in the Grid Extents frame
Y Min = 0 in the Grid Extents frame
Y Max = 13.636 in the Grid Extents frame
Cell width = calculated this value can be adjusted as per project requirements
Cell height = calculated this value can be adjusted as per project requirements
Number of Layers = 1
Layer1 - Top Elevation = 6
Layer1 - Bottom Elevation = -156

The screen should now look like the image below:

· [Create Grid] button at the top-left of preview window

The Model Explorer (the lower left section of the interface) will be populated with the newly
created model structure items. You will also see 2 new surfaces created in the Data Tree.
These surfaces represent the top and bottom surfaces of the model layers and are
consequently transformed automatically into ‘Horizons’ in the Model Explorer. Each pair of
horizons in turn defines a zone, so you will also notice one new zone in the Model Explorer.
Your grid has been created and you’ll notice that the Properties section of the model
structure is empty, so the next step will be to define boundary conditions and the model
properties. The ‘View/Edit Grid’ portion of the workflow allows the user to make any
necessary changes to the grid structure. This will be particularly useful for us, since we need
to refine our initial grid vertically to have 27 layers (as defined by the original Elder model).
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· Click [

] (Next Step) to proceed to the View/Edit Grid step

In the middle of the interface you will see a Toolbox. The buttons under this toolbox allow
you to edit the grid in the horizontal direction (i.e. Edit Grid…), to edit the grid in the vertical
direction (i.e. Edit layers…), to extract a subgrid from your model (i.e. Create subgrid…), or
to assign model cells as active/inactive (i.e. the Inactive Cells frame). We will utilize the Edit
layers functionality to refine our initial single layer grid, and then use the Inactive Cells
feature to deactivate several flow cells in the top model layer.
·
·
·
·
·

Click the [Edit layers…] button under the Toolbox
Type: FinalGrid in the New grid name field
Type: 27 in the By a factor of field
Click the [Apply edit] button at the bottom left
The window should look like the following:

· Finalize the layer edit by clicking [OK]

Once again you should see that the Model Explorer will be populated with the newly created
model structure items, and a new workflow window will open. We will continue working with
the FinalGrid workflow, so feel free to minimize the initial grid in the Model Explorer, and
close the initial workflow window:
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The final change to the grid is to specify two inactive areas in model layer #1. To make this
change we will activate the Row view (Row 1) and assign inactive cells using the polyline
drawing function:
·
·
·
·
·
·
·
·
·

þ Row in the Views frame, to activate Row view

Layer in the Views frame, to deactivate Layer view
Exaggeration: 5 in the field above the viewer to decrease the vertical exaggeration
[Assign] > [Using Polyline] button under the Toolbox, under Inactive Cells
Draw a polyline in layer 1, from Column 1 to 11 (click once to start, double-click
to finish)
Draw another polyline in layer 1, from Column 34 to 44 (click once to start,
double-click to finish)
[Finish] button under the Toolbox
[OK] in the Copy to Row(s) window that appears
The final grid should look like the image below:

© 2022 by Waterloo Hydrogeologic

11

Visual MODFLOW Flex 8.0 Help

We have now recreated the grid as required by the Elder model and are ready to proceed to
the next step in the workflow, which is to define property values.
· Click [

] (Next Step) to proceed to the Define Properties step

Define Properties
You should now be viewing the Define Properties workflow step. You may want to inspect
that the model properties are set according to the default property values that you defined
during the Define Modeling Objectives step. Select any of the properties from the toolbox
and click on the Edit… button, and you will see the values assigned to each cell of the model
for the respective property. For example, the image below displays the Edit Property window
for the conductivity property group:
· Click [Edit...] in the Toolbox to open the Edit property window for a given property

group
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· Click [OK] in the dismiss the Edit property window

Remember that at any step during the numerical workflow you have the possibility to inspect
your grid in four different views: plan, two cross-section views and a 3D view. These views
can be toggled on and off by checking the respective check-boxes in the Views area. Make
sure you are looking at Row 1 in the Layer View window. If you have more viewer windows
open, make sure that Row View is the active window, as shown in the image below:

Now we will assign property values as shown in the following image:
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We will begin with the conductivity values for the top and bottom model layers:
· Select [Conductivity] from the first menu in the Toolbox frame
· Click [Assign] > [Polyline] buttons under the Toolbox
· Type: 5 in the [Exaggeration] field above the viewer to decrease the vertical

exaggeration
· Draw a polyline across all of layer 1 (click once to start, double-click to finish)
· Draw another polyline across all of layer 27 (click once to start, double-click to

finish)
· Click [Finish] button under the Toolbox
· The New Property Zone window will open.

In this window we will assign the selected cells to a New property zone, and apply the
desired Kx, Ky and Kz values (i.e. 1E-05 m/day).
·
·
·
·

[New] button at the top-left of the window, to create a new property zone
Type: 1E-05 in the Value field for Kx, Ky and Kz
[OK] to accept inputs and create the new property zone
The New Property Zone window should look like the image below before clicking
[OK]:
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We will repeat this process for initial concentrations, assigning a value of 285,700 mg/L for
layer 1 ONLY.
·
·
·
·
·
·
·
·

Select [Initial Concentration Salt] from the first menu in the Toolbox frame
Click [Assign] > [Polyline] buttons under the Toolbox
Draw a polyline across all of layer 1 (click once to start, double-click to finish)
Click [Finish] button under the Toolbox
The New Property Zone window will open
Click the [New] button at the top-left of the window, to create a new property zone
Type: 285700 in the Value field for Concentration
[OK] to accept inputs and create the new property zone

The remaining changes to property values will be made to the entire model, so we can use
the Edit function rather than assigning new property zones using the drawing tools. We will
update the effective and total porosity values (through the Storage property group) and
longitudinal dispersivity (through the Dispersion property group).
· Select [Storage] from the first menu in the Toolbox frame
· Click [Edit...] button under the Toolbox
· Type: 0.1 in the Effective Porosity column, then use [F2] to propagate through all

cells
· Type: 0.1 in the Total Porosity column, then use [F2] to propagate through all cells
· [OK] to accept inputs and create the new property zone
· Select [Dispersion] from the first menu in the Toolbox frame
· Click [Edit...] button under the Toolbox
· Type: 0 in the Longitudinal dispersivity (m) column, then use [F2] to propagate

through all cells
· [OK] to accept inputs and create the new property zone
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Finally, one final change must be made to the model level dispersion parameters. These can
be accessed by right-clicking the Dispersion property group under the Model Explorer and
selecting Dispersion Parameters as shown in the image below:
· Right-click Dispersion from the Model Explorer (under FinalGrid1 > Run1 > Inputs >

Properties > Transport)
· Click [Dispersion Parameters] from the menu that appears

· The Dispersion Parameters window will open
· Type: 0.308 in the Diffusion Coeff. (m^2/day) field, then use [F2] to propagate

through all cells
· Click [OK] to confirm and assign values
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Note: this diffusion coefficient is the modelwide molecular diffusion coefficient. This is
different than the species-specific diffusion
coefficient applied during the Define Modeling
Objectives step. The species-specific value is only
used if the multi-diffusion option is set to true in the
DSP package advanced translation settings.
Now is a good time to save the project.
· Click [File] > [Save Project] from the main menu

Define Boundary Conditions
If you are satisfied with the property values assigned to the model, advance to the Define
Boundary Conditions step in the numerical workflow. We will assign the model boundaries
in Row view.
· Click [

] (Next Step) to proceed to the Define Boundary Conditions step

At this stage we will assign boundary conditions to our model, starting with a constant head
boundaries at the top-left and top-right corners of the model (see the figure at the very
beginning of this tutorial). We will do this by simply selecting the two desired cells.
·
·
·
·
·
·

[Constant Head] from the first menu under the Toolbox
[Assign] > [Cells] from the menu under the Toolbox
Left-click once in Layer 2, Row 1, Column 1
Left-click once in Layer 2, Row 1, Column 44
Click [Finish] under the Toolbox
The Define Boundary Condition window will open
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· Click [Next>>] to accept default name and proceed

We will assign a constant head value of 0 m to both of the selected cells. For both cells, type
a value of 0 in the starting and ending head fields, select Specified Density as the density
option, and apply a density of 1000 kg/m3.
·
·
·
·

Type: 1E-6 in the Starting Head (m) field, for both cells/rows
Type: 1E-6 in the Ending Head (m) field, for both cells/rows
Select Specified Density in the Density Option field, for both cells/rows
Type: 1000 in the Density (kg/m^3) field, for both cells/rows

· Click the [Finish] button to finalize and create the constant head boundary condition

You will notice that both of the selected cells will be populated with red dots. These red dots
represent the newly created boundary condition. Boundary conditions within Visual
MODFLOW Flex are color-coded for quick identification.
We will now apply two constant concentration boundary conditions. In the top layer we will
apply a high salt concentration (285.7 kg/m3), and in the bottom layer we will apply a
constant concentration of 0 kg/m3. This concentration gradient is what will drive water flow
and solute transport in this model.
· [Constant Concentration] from the first menu under the Toolbox
· [Assign] > [Polyline] from the menu under the Toolbox
· Draw a polyline across active zone of layer 1 (click once to start, double-click to
·
·
·
·
·

finish)
Click [Finish] under the Toolbox
The Define Boundary Condition window will open
Click [Next>>] to accept default name and proceed
Type: 285700 in the Salt (mg/L) field, then use [F2] to propagate through all cells
Click the [Finish] button to finalize and create the constant head boundary condition
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SEAWAT Tutorial

18

Note: if the drawn polyline extends into the
inactive zone, you may see a Resolve validation
failures window appear. In this case it is simply
identifying that some of the selected cells are in
the inactive zone, and the boundary conditions for
those cells can either be deleted or the cells can
be reactivated. The default solution will be to
Delete invalid cells. If you DO see this window,
simply click Apply then Close to resolve potential
validation errors.
Now we will repeat the steps above to apply a constant concentration of 0 mg/L to the lowest
model layer.
· [Constant Concentration] from the first menu under the Toolbox
· [Assign] > [Polyline] from the menu under the Toolbox
· Draw a polyline across active zone of layer 27 (click once to start, double-click
·
·
·
·
·

to finish)
Click [Finish] under the Toolbox
The Define Boundary Condition window will open
Click [Next>>] to accept default name and proceed
Type: 0 in the Salt (mg/L) field, then use [F2] to propagate through all cells
Click the [Finish] button to finalize and create the constant head boundary condition

Now all of the desired boundary conditions have been applied across the entire model
domain. Your display should look something like the image below. Note the beige dots in
layers 1 and 27, indicating the presence of the constant concentration boundaries. Also note
the red dots indicating the constant head boundaries in layer 2 (top-left and top-right).
Finally, note how each new boundary condition has been added into the Model Explorer.
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We now have enough data to run this density-driven flow model, but first we have to define
our model translation settings.
Translate and Run the SEAWAT Model
Navigate to the Select Run Type > Single Run step in the numerical workflow. You may
click directly on this step as it is colored green, or you can navigate there step-by-step using
the navigation arrows at the top of the workflow window.
· Click [Single Run] from the Workflow Navigator, to proceed directly to the Single Run

workflow step
You will be prompted to select which engines to run. By default, USGS SEAWAT from WH
should already be selected. This is because this is the only flow engine within Visual
MODFLOW Flex that allows you to model density-dependent flow. If you click on the Flow
Engine menu you will see that USGS SEAWAT from WH is the only available option. The
engine settings should look like the image below:
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You will now advance to the Translate step of the workflow. This step will translate all the
input data defined for the model into “packages” (i.e. text files) that can be run by SEAWAT.
· Click [

] (Next Step) to proceed to the Translate step

The translation settings will appear; this allows you to adjust solvers and their parameters
(number of iterations, head-change criterion, damping factors), package settings, output
control, etc.. In the Settings section of the SEAWAT branch you can change the SteadyState Simulation Time to 7300 by entering this value directly.
·
·
·
·
·
·
·

Go to the [SEAWAT] > [Settings] section of the menu
Select BCF6 in the Property Package field.
Dismiss the warning about the VSC package which will be turned off later
Type: 7300 in the Steady-State Simulation Time field
Select Transient in the Run Type field
Type: 20 in the Time Steps field
Type: 1 in the Multiplier field

·
·
·
·
·
·
·

Go to the [SEAWAT] > [Solvers] section of the menu
Select Conjugate Gradient Solver (PCG) in the Selected Solver field
Type: 50 in the Max. Outer Iterations (MXITER) field
Type: 25 in the Max. Inner Iterations (ITER1) field
Type: 1.0E-7 in the Head Change Criterion (HCLOSE) field
Type: 1 in the Residual Criterion (RCLOSE) field
Type: 5 in the Printout Interval (IPRPCG) field

· Go to the [SEAWAT] > [Layers] section of the menu
· Apply layer type ‘0: Confined, constant S,T’ for ALL layers
·
·
·
·

Go to the [SEAWAT Transport] > [General] section of the menu
Select Total in the Porosity Options field
Type: 0.1 in the Courant Number field
Type: 0.05 in the Min. Sat. Thickness field
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·
·
·
·
·
·
·
·

Go to the [SEAWAT Transport] > [Solution Method] section of the menu
Select Central Finite Difference (CFD) in the Advection Method field
Select Yes in the Use Implicit GCG Solver field
Type: 1E-08 in the Relative Convergence Criterion field
Type: 5 in the Concentration change printing interval field
Select Modified Incomplete Cholesky in the Preconditioners field
Type: 30 in the Initial step size (DT0) (days) field
Type: 0 in the Max step size (days) field

· Go to the [SEAWAT Transport] > [Output Control] section of the menu
· Type: 7300 in the Simulation time length (project time units) field
· Type: 3000 in the Max number of transport steps field
· Click
[Add row] x6 press the Add row button six times to specify six output times
· Type: 365 [press Tab], 730 [press Tab], 1095 [press Tab], 3650 [press Tab], 5475

[press Tab] and 7300 as the desired output times in each row
The solver settings window for the Output Control section should look like the image below:

It is also important to know that individual settings for the SEAWAT variable-density flow
(VDF) and viscosity (VSC) packages can be set through the SEAWAT Transport >
Advanced Settings menu.
The VDF translation menu allow you to specify how groundwater densities are calculated
using the Density Option setting (i.e. using salt only, using multiple species, or using userspecified densities), how internodal density is calculated (i.e. central-in-space or upstreamweighted algorithm), whether a variable density water table correction is applied or not, and
to specify constants such as minimum/maximum fluid density, and a reference fluid density.
· Go to the [SEAWAT Transport] > [Advanced Settings] > [VDF] section of the menu

© 2022 by Waterloo Hydrogeologic

SEAWAT Tutorial

22

· Select Up-stream weighted algorithm in the Intermodal density calculation

algorithm field
· Select Not applied in the Variable density water table correction field
· Type: 0.001 in the Initial Time Step field
· Select the Explicit coupling using one iteration option

The VSC translation settings allow you to specify how groundwater viscosities will be
calculated in the simulation. The Viscosity Option setting allows you to choose whether
viscosity is calculated using salt only (no temperature dependence), using temperature and
additional species (e.g. salt), or whether specifies viscosities will be used. You can also
specify constant values such as maximum, minimum and reference viscosities in this menu.
If you access the VSC translation settings menu you should see the following:
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However, we do not actually want to run the .VSC package in this simulation, assuming that
there is no viscosity effects at higher concentrations. To remove the .VSC package from this
model we will change both the ‘Run’ and ‘Translate’ fields to ‘No’.
· Select [No] in the Run field
· Select [No] in the Translate field

At this time the desired translation settings have all been specified and we can proceed to
translating the model input files.Press the translate button to begin the translation process.
As soon as you click the translate button Visual MODLFOW Flex will begin translating all the
required input files for a SEAWAT model.
· Click [

] to create the SEAWAT input packages. Check the log to confirm
the translation has finished.
· Click [Yes] to dismiss the warning about initial heads
A translation log will run for a few moments and should terminate with the following
message:

######################## Translation Finished ########################
You should also see a series of new tabs at the top of the translation window, corresponding
to the various input files which have been generated. You can click these tabs to view the
contents of each input file. You can also click the open file button [
] to open the folder
containing the input files. If you aren’t happy with the translated files you can always return to
the Settings tab, make changes and retranslate the files. For this model run you won’t need
to make any further changes.
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You may now proceed to the Run Numerical Engines step.
· Click [
· Click [

] (Next Step) to proceed to the Run step
] to run the SEAWAT model

The numeric engines will start running and display progress in the main window. SEAWAT
will run first followed by any secondary engines selected during the Single Run workflow
step (e.g. MODPATH or ZoneBudget; we haven’t selected any additional engines in this
model). Each engine will have an information window that displays simulation results and
progress. Clicking on the tab of the respective window will enable you to view detailed results
of each run. When your model is finished running your results screen should look like the
image below:
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If you would like to inspect a record of the run process you may open the listing (.LST) file by
clicking on the Open Engine Files… button [
] at the top of the window. The model run
may take several minutes to complete, since SEAWAT models are more complex than most
contaminant transport models. A SEAWAT model may take 2-4 times longer to run than a
MODFLOW model of the same dimensions due to the coupling of flow and transport
processes.
Output Visualization
To see the results of the simulation navigate to View Results -> View Maps in the workflow
tree. Equipotentials will be shown in plan view by default. You may want to change your map
appearance by using the icons at the top of the window and/or right clicking on Heads in the
Model Explorer and select Settings…. To see your equipotentials and the water table in
cross-section activate the Row viewer (put a check-mark) and select the row number along
which you would like to inspect the results.
· Click [

] (Next Step) to proceed to the View Results step
© 2022 by Waterloo Hydrogeologic

SEAWAT Tutorial

26

· Click [View Maps] to proceed to the View Maps workflow step
·
Row in the Views frame, to activate Row view

þ

·

Layer in the Views frame, to deactivate Layer view

Depending on your settings, you should see something like the figure below:

Note: you can maximize the viewer window by
deactivating the Model Explorer and/or Workflow
Navigator panels. Use the toolbar buttons [
to turn these panels on/off.

]

To better visualize the flow field in the model domain you can activate the Velocity outputs
under the Model Explorer. The velocity flow field indicates that the diffusive flux of salt in the
model domain is driving water flow in two recirculation cells, with the greatest flow velocities
in the middle of the model and circulating upward toward the edge of the model where the
constant heads boundaries have been applied.
· Activate
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þ Velocity under the Outputs/Flow section of the Model Explorer
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Note: if the velocities don’t match the figure
above initially, try toggling the velocities and/or
selecting 7300 from the time control bar in the
toolbar.
Now you may activate the concentration results, which will display the diffusion of salt
throughout the model domain at different output times:

þ
þ

· DeActivate
Heads under the Outputs/Flow section of the Model Explorer
· DeActivate
Velocity under the Outputs/Flow section of the Model Explorer
· Activate
Concentration (Salt) under the Outputs/Flow section of the Model

þ

Explorer
· Press the last time step button [

] in the time controls
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Note: if the contours don’t match the figure
above initially try right-clicking ‘Concentration
(Salt)’ from the Model Explorer, accessing the
contour line settings and updating the minimum
contour level to 0 mg/L.
You can use the time-step picker buttons above the Flex viewer to display the concentration
results at various output times. If you update the viewer to display the results at day 365 you
should see something like the image below:
· Press [
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] under the Outputs/Flow section of the Model Explorer
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Using the cell-inspector tool, review salt concentrations throughout model layer 2 and you
should notice some unusual results.
· Press [

] under the Outputs/Flow section of the Model Explorer

The Cell Inspector window will open, allowing you to select which information will be
displayed on a cell-by-cell basis. We’re only interested in the results of the model run, so we
can deactivate the position, properties, and boundary conditions categories:
·

Position to turn off position information

·

Properties to turn off properties information

·

Boundary Conditions to turn off boundary condition information

·

Budget turn off the flow budget information
· Click once on Layer 2, Row 1, Column 11
The Cell Inspector window will now display the results of the simulation for the selected cell,
as shown in the image below. You can see from these cell inspector results that the salt
concentration in cell 2, 1, 11 is -43,772 mg/L. These results clearly include non-physical
values (e.g. negative concentrations) and can be attributed to truncation errors and/or
numerical dispersion associated with the selected solution method for the transport equation
(i.e. Central Finite Difference method).
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You can improve the results by adjusting the solution method inputs. Return to the Translate
workflow step and make the following changes:
· Click [Translate] directly from the workflow navigator, to return directly to this workflow

step
· Go to the [SEAWAT] > [Solvers] section of the menu
· Type: 0.01 in the Residual criterion (RCLOSE) field
·
·
·
·
·

Go to the [SEAWAT Transport] > [Solution Method] section of the menu
Select Total Variation Diminishing (TVD) in the Advection Method field
Type: 20 in the Max. number of outer iterations field
Type: 100 in the Max. number of inner iterations field
Type: 1E-09 in the Relative Convergence Criterion field

Now re-translate and re-run the model
· Click [

] directly from the workflow navigator, to return directly to this
workflow step
· Click [No] to dismiss the warning(s) about No package data
· Click [Yes] to dismiss the warning about initial heads
· Click [
· Click [
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] (Next Step) to proceed to the Run step
] to run the SEAWAT model
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When the model is finished running you should see the following results for salt
concentrations at day 365 and 7300, respectively. You can also double-check salt
concentrations throughout layer 2 to ensure that no negative concentrations are present:
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Compare the contours at day 365 and 7300 to the following published results (Guo and
Langevin, 2002):
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Figure reference: Guo and Langevin (2002), page 74.
Note: concentrations in the published results
are displayed as a percentage of the constant
concentration at the top of the model. In the default
Visual MODFLOW Flex output the concentrations
are displayed as absolute values.
Now is a good time to save the project. Click [File]>[Save Project] from the main menu.
*****This concludes the 'SEAWAT - Elder Model' tutorial.*****
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